Hi!
This is something that I've discovered in my lab configuration, and now I'm not quite sure of how to report/confirm this. So I thought I'd start here.
What started this was that after having successfully installed vSphere 5.5 on my iSCSI LUN, which was mounted through iBFT, I kept getting various errors about corruption when trying to boot the now installed ESXi image.
It was either a purple screen, saying:
"Could not load multiboot modules: Boot image is corrupted".
Or during the loading of components, on the initial boot sequence, I would get something like:
error loading /s.v00
fatal error: 33 (inconsistent data)
After googling and troubleshooting this for a couple of hours, trying numerous reinstalls, confirming installation media hash sums, etc, etc.. I decided to test that this wasn't a network issue of some kind.
To do this, I thought I'd start with simplifying the configuration on the host, by only connecting one network adapter to begin with.
Lo and behold, it booted right away. This was after it just moments ago told me that my boot image was corrupted on the previous boot attempt. No other changes were made.
To confirm that it was indeed an issue with multiple network adapters, I reconnected a second adapter on the host, and rebooted. Result: "Boot image is corrupted".
So my prevailing theory as of now is that the algorithms used by the hypervisor/esxi to confirm if the data is "inconsistent" or "corrupted" cannot handle that the data is comming from multiple interfaces on the storage unit. As is the case with my storage, which is configured with 2 interfaces that are link aggregated with LACP.
Here's an overview of my lab environment as it is configured now:
The relevant switch configuration:
!
interface port-channel 1
description STORAGE-001
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 100,2000
!
interface ethernet g1
channel-group 1 mode auto
description STORAGE-001-1
spanning-tree portfast
!
interface ethernet g2
channel-group 1 mode auto
description STORAGE-002-2
spanning-tree portfast
!
interface ethernet g5
description ESX-001-1
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 100,2000
!
interface ethernet g6
description ESX-001-2
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 100,2000
!
As you can see, the storage interfaces use link aggregation with LACP, while the ESXI interfaces are simply trunked, with no relation to each other.
Hope someone can help confirm this, or maybe provide some tips on how I can troubleshoot this further in order to find out why this configuration isn't working, which is should...
--
Max